re = /(^[^\s(]|\s[^\s(])[^()\s]*(?=\s|$)/m
str = 'Test test test (test). Test (test test) test test.'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result