use strict;
my $str = 'dgxxxxbfbb sjadlasgdlgasli
shadcksavdlcvlas
ashccjhlasvhlcvlasdhc
skjbckjsajc
hjvjcjjhchgcjh
hgcjhcjc hjgchj
ghjxgxng';
my $regex = qr/\n/mp;
my $subst = '\\b';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";