$re = '/^(?:[^\/\n]*\.)?(?:google|bing)\.(?:de|com|net)$/m';
$str = 'google.de
sub.google.de
www.xxx.google.de
bing.com
www.lala.de/bla/?r=www.google.de';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);