package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[\[.+?)(\/)([^|\[\]]+?\]\])`)
var str = `[[Obsidian/Deep Links]] and [[Obsidian/Deep Links]]`
var substitution = "$1#$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}