use strict;
my $str = '[[Obsidian/Deep Links]] and [[Obsidian/Deep Links]]';
my $regex = qr/(\[\[.+?)(\/)([^|\[\]]+?\]\])/mp;
my $subst = '$1#$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";