import Foundation
let pattern = #"(\[\[.+?)(\/)([^|\[\]]+?\]\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[[Obsidian/Deep Links]] and [[Obsidian/Deep Links]]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"$1#$3"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)