#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=[A-Z])\s+(?=[A-Z])"
Local $sString = "I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)