re = /(?<=[A-Z])\s+(?=[A-Z])/
str = 'I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result