import Foundation
let pattern = #"(?<=[A-Z])\s+(?=[A-Z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"I ES P E ES P 010 000 000 000 000 000 001 001 000 000 IESP 000 000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)