using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ORDER\n(.*)";
string input = @"FILTER
prefix#file
ORDER
abs
FILTER
suffix#.txt
ORDER
RRsize";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}