re = /^(.*?)\s*(?:\[([^\]]*)\])?$/m
str = 'aaaaa [] [ddd]
[] [ddd]
aaaaaaaa
aaaaaaaa []
aaaaaa [
aaaa [] ddd
[a] [b] [c] [d]
[fff]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end