using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(END).*?(START)";
string input = @"STARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerENDetrtwtw
asdasdSTARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerEND";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}