use strict;
my $str = 'STARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerENDetrtwtw
asdasdSTARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerEND';
my $regex = qr/(END).*?(START)/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}