import Foundation
let pattern = #"(END).*?(START)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
STARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerENDetrtwtw
asdasdSTARTsadasd
asdasd
asdasd
asdas
das
dasdasdasd
asdasd
sadasdENDasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadSTARTsdasfgsdhtrwe
asdasdasdasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
sadadsdENDsadasd
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
START
asdasd
asdasdasf
asdfsdfsdf
sdfsd
fsdf
sdfasdsad
sd
fsd
fsdfsdfsdf
AsdgrrgerEND
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)