const regex = /(\w+)="(.*?)(?<!\\)"/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)="(.*?)(?<!\\\\)"', 'gs')
const str = `time="2015-06-21T11:33:26+02:00" level="fatal" msg="Error response from daemon: Conflict. The name \\"test\\" is already in use by container XXXXXXXX. You have to delete (or rename) that container to be able to reuse that name."`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}