re = /(\w+)="(.*?)(?<!\\)"/
str = 'time="2015-06-21T11:33:26+02:00" level="fatal" msg="Error response from daemon: Conflict. The name \\"test\\" is already in use by container XXXXXXXX. You have to delete (or rename) that container to be able to reuse that name."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end