using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@if\([^()]*\)(?<!\(null\))\s*(.*?)\s*@end$";
string input = @"@if(Medellin) City Medellin @end
@if(null) City Medellin @end
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}