import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<test(?!.+href).+";
final String string = "<test abc=\"xyz_CHCFGRc/abc_CHmnop\" href=\"sdddzus.xml\">text</test>\n"
+ "<test abc=\"abc_abc>text23</test>\n"
+ "<test abc=\"123_ABCc/abc_CHmnoph\">text42</test>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}