#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([^\\]+)\\(\S+)\s([^\\]+)\\([^\\]+)\\(.+)"
Local $sString = "Projects\UP/PS (21063)\2789 (spain) / Ref/15\Email" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"casi, serían 1=Projects (pero es tan facil que lo he obviado), 2=UP/PS, 3=(21063), 4=2789 (spain) / Ref/15, 5=Email"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")