package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^\\]+)\\(\S+)\s([^\\]+)\\([^\\]+)\\(.+)`)
var str = `Projects\UP/PS (21063)\2789 (spain) / Ref/15\Email
casi, serían 1=Projects (pero es tan facil que lo he obviado), 2=UP/PS, 3=(21063), 4=2789 (spain) / Ref/15, 5=Email`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}