using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Mr\. |Miss\. |Master. |Mrs)";
string input = @"Cumings, Mrs. John Bradley (Florence Briggs Thayer)
Braund, Mr. Owen
Heikkinen, Miss. Laina
Futrelle, Mrs. Jacques Heath (Lily May Peel)
Palsson, Master. Gosta Leonard
Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)
Uruchurtu, Don. Manuel E";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}