package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Mr\. |Miss\. |Master. |Mrs)`)
var str = `Cumings, Mrs. John Bradley (Florence Briggs Thayer)
Braund, Mr. Owen
Heikkinen, Miss. Laina
Futrelle, Mrs. Jacques Heath (Lily May Peel)
Palsson, Master. Gosta Leonard
Vander Planke, Mrs. Julius (Emelia Maria Vandemoortele)
Uruchurtu, Don. Manuel E`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}