$re = '/^ *([A-z0-9.]*)\(([0-9]+)\)/m';
$str = '..\\win32_proceduralmusic.cpp(62) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(63) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(64) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(65) : error C2065: \'CS_USEDEFAULT\' : undeclared identifier
..\\win32_proceduralmusic.cpp(72) : error C2059: syntax error : \'=\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);