import Foundation
let pattern = ##"#(\w*[0-9a-zA-Z]+\w*[0-9a-zA-Z])"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
//only accept az AZ and _ (underscore)
#teste_teste //underscore accepted
#teste-teste //Hyphen not accepted
#leof_gfg.sdfsd //dot not accepted
#f34234@45#6fgh6 // @ not accepted
#leo#leo2#asd //followed hastag without space
#6663 // only number accepted
_#asd_ // hashtag can't start or finish with underscore
-#sdfsdf- // hashtag can't start or finish with hyphen
.#sdfsdf. // hashtag can't start or finish with dot
#leo_leo__leo__leo____leo //TO FIX: decline followed underline
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)