re = /class="((\s|[a-zA-Z_-]{1}[\w-_]+)+)"/
str = '
<tag class="something else">yeah {{node.node}} </tag>
<tag class="class1 class2">yeah {{node.node}} </tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end