// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\+|\-)?\d+(\.\d+)?").unwrap();
let string = "sdfhsdfh-78923.3525.235235ksjghdkfgsdgsghsdfgdfg898908fghdfhdhdfh678980dfh
0.12
0000.1245";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}