#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?:.*?May 2016){3}\K.*?(?=Jun 2016)"
Local $sString = "May 2016 ef Jun 2016 efef May 2016 Jun 2016 May 2016" & @CRLF & _
"" & @CRLF & _
"dffdg def efef" & @CRLF & _
"" & @CRLF & _
"Jun 2016" & @CRLF & _
"" & @CRLF & _
"May 2016" & @CRLF & _
"" & @CRLF & _
"Jun 2016" & @CRLF & _
"" & @CRLF & _
"foo bar" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")