const regex = /([^\s]+)(\.*)\.(pdf|gif|png|jpg|jpeg)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s]+)(\\.*)\\.(pdf|gif|png|jpg|jpeg)', 'g')
const str = `fileadmin/example.de/Images/dummy_001.jpg color2 Dies ist ein Test Hier steht Text Test fileadmin/example.de/Beispielinhalte/Images/test/etest/test/test/test/test/dummy_002.jpg color3 Testin DIes ist ein Test Testing fileadmin/example.de/Beispielinhalte/Images/dummy_003.jpg color4 Das ist ein weiterer Test Dies ist ein Test Test fileadmin/example.de/Beispielinhalte/Images/dummy_005.jpg color5 Überschrift Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Link-Titel /fileadmin/example.de/Beispielinhalte/Images/dummy_007.jpg color2 Überschrift Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Link-Titel fileadmin/example.de/Beispielinhalte/Images/dummy_008.jpg color1 Überschrift Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam et justo duo dolores et ea rebum. Stet clita kasd gubergren, no sea takimata sanctus est Lorem ipsum dolor sit amet. Link-Titel`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);