#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!\.)([0-9]{3}\.[0-9]{3}\.[0-9]{3})(?!\.)"
Local $sString = "Affected IDs:" & @CRLF & _
"641.298.855 (this, lead)" & @CRLF & _
"213.794.868" & @CRLF & _
"948.895.285"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")