$re = '/^(?!\.)([0-9]{3}\.[0-9]{3}\.[0-9]{3})(?!\.)/m';
$str = 'Affected IDs:
641.298.855 (this, lead)
213.794.868
948.895.285';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);