$re = '/(?:(rgb\([^)]*\)|\S+)(?:[ ]+)?)*/';
$str = '1px solid rgb(255, 255, 255) test rgb(255, 255, 255)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);