#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(category)/([^/]+)/([^/]+)/((?:(?!\bitem\b).)+)/([^/]+)/?$"
Local $sString = "category/all-weather-wicker/bermuda/table/2977/" & @CRLF & _
"category/all-weather-wicker/bermuda/item/2977/" & @CRLF & _
"category/all-weather-wicker/bermuda/foo/2977/" & @CRLF & _
"category/all-weather-wicker/bermuda/item/2977/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")