using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(category)/([^/]+)/([^/]+)/((?:(?!\bitem\b).)+)/([^/]+)/?$";
string input = @"category/all-weather-wicker/bermuda/table/2977/
category/all-weather-wicker/bermuda/item/2977/
category/all-weather-wicker/bermuda/foo/2977/
category/all-weather-wicker/bermuda/item/2977/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}