#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/(\d+).*"
Local $sString = "pagePath" & @CRLF & _
"/text/other_text/123-some_other_txet-4571/text.html" & @CRLF & _
"/text/other_text/another_txet/15-some_other_txet.html" & @CRLF & _
"/text/other_text/25189-some_other_txet/45112-text.html" & @CRLF & _
"/text/other_text/text/text/5418874-some_other_txet.html" & @CRLF & _
"/text/other_text/text/text/some_other_txet-4157/text.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")