import re
regex = re.compile(r"^(?:https?:\/\/)?(?:(?:www\.)?youtube\.com\/(?:(?:v\/)|(?:embed\/|watch(?:\/|\?)){1,2}(?:.*v=)?|.*v=)?|(?:www\.)?youtu\.be\/)([A-Za-z0-9_\-]+)&?.*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = "https://www.youtube.com/watch?v=L-iepu3EtyE&ab_channel=systemofadownVEVO"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)