#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(("[^"]+" *[+] *)+)("[^"]+";)"
Local $sString = ""039b7" + "7ea14" + "68912" + "909"; " & @CRLF & _
""7" + "c" + "7" + "5" + "d" + "1" + "e" + "f" + "1" + "4" + "6" + "8" + "9" + "1" + "2" + "9" + "9" + "4"; " & @CRLF & _
""13edf9" + "1a1468" + "913272"; "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")