using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((""[^""]+"" *[+] *)+)(""[^""]+"";)";
string input = @"""039b7"" + ""7ea14"" + ""68912"" + ""909"";
""7"" + ""c"" + ""7"" + ""5"" + ""d"" + ""1"" + ""e"" + ""f"" + ""1"" + ""4"" + ""6"" + ""8"" + ""9"" + ""1"" + ""2"" + ""9"" + ""9"" + ""4"";
""13edf9"" + ""1a1468"" + ""913272""; ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}