use strict;
my $str = '"039b7" + "7ea14" + "68912" + "909";
"7" + "c" + "7" + "5" + "d" + "1" + "e" + "f" + "1" + "4" + "6" + "8" + "9" + "1" + "2" + "9" + "9" + "4";
"13edf9" + "1a1468" + "913272"; ';
my $regex = qr/(("[^"]+" *[+] *)+)("[^"]+";)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}