import Foundation
let pattern = #"(("[^"]+" *[+] *)+)("[^"]+";)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"039b7" + "7ea14" + "68912" + "909";
"7" + "c" + "7" + "5" + "d" + "1" + "e" + "f" + "1" + "4" + "6" + "8" + "9" + "1" + "2" + "9" + "9" + "4";
"13edf9" + "1a1468" + "913272";
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)