$re = '/(?|\{([^}]*)\}|\[([^]]*)\])/x';
$str = '[a1][a2]{a3}[b1][b2]{b3}[c1][c2]{c3}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);