// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(?|\{([^}]*)\}|\[([^]]*)\])").unwrap();
let string = "[a1][a2]{a3}[b1][b2]{b3}[c1][c2]{c3}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}