using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b([0-9]{1,2})-([a-zA-Z]+(?:\s+[a-zA-Z]+))\b";
string input = @"1-New Bathroom 2-New Kitchen 3-New Garden 4-Caribbean Holiday";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}