package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([0-9]{1,2})-([a-zA-Z]+(?:\s+[a-zA-Z]+))\b`)
var str = `1-New Bathroom 2-New Kitchen 3-New Garden 4-Caribbean Holiday`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}