$re = '/\b([0-9]{1,2})-([a-zA-Z]+(?:\s+[a-zA-Z]+))\b/m';
$str = '1-New Bathroom 2-New Kitchen 3-New Garden 4-Caribbean Holiday';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);