// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b([0-9]{1,2})-([a-zA-Z]+(?:\s+[a-zA-Z]+))\b").unwrap();
let string = "1-New Bathroom 2-New Kitchen 3-New Garden 4-Caribbean Holiday";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}