#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)^server +\{\s+(abcdefg.+?\n\}.*?$)"
Local $sString = "server {" & @CRLF & _
" abcdefg blablablabla" & @CRLF & _
" pizza" & @CRLF & _
" #blablablabla" & @CRLF & _
" blablablabla {" & @CRLF & _
" zazazazazaza" & @CRLF & _
" }" & @CRLF & _
" turtles" & @CRLF & _
" #}" & @CRLF & _
" ninjas" & @CRLF & _
" blablablabla" & @CRLF & _
"" & @CRLF & _
"} #comments that might or might not be here" & @CRLF & _
"" & @CRLF & _
"server {" & @CRLF & _
" blablablabla" & @CRLF & _
" blablablabla" & @CRLF & _
" blablablabla" & @CRLF & _
" blablablabla" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"zabzazab" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")