$re = '/^(?!.*(,\sso\b)).*$/m';
$str = 'So that
so big that
, so
and not , so';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);