use strict;
my $str = '1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
88
feb 3
february 10';
my $regex = qr/\d+(\-[XIV]+)*(\-\d+)*/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}