import Foundation
let pattern = #"\d+(\-[XIV]+)*(\-\d+)*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1 2 3 the
the quick 2354
feb 1
feb 0
feb -10
feb23
88
feb 3
february 10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}