# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|[^_])\bproducts\b([^_]|$)/$1.$2/g;t' <<< "{% macro products_list(products) %}
{% for product in products %}
productsList
{% endfor %}
{% endmacro %}"